Tienda | Foros | Blogs | EN |
 

Pctel (hsp) MR

Seguir
donde consigo un driver para este modem con un kernel 2.2.40
gracias y hasta pronto!
Nach0


5 Soluciones propuestas

Hola Nach0,


Fijate acá, supuestamente son los drivers, además tiene referencias a más documentación sobre winmódems en Linux. Un sitio recomendable para este tema es http://www.linmodems.org.

Saludos.

P ¿Pudiste sortear los otros problemas? Si es así por favor contá como hiciste.
Si pude solucionarlo Mauricio, parece que era que en el puerto USB tenia conectado un jostick y parece que hacia lio, lei en un foro por ahi eso, lo saque y todo bien. lo malo es que el lilo durante la instalacion no se me quizo instalar ni en el mbr ni en root; tengo que bootear con un diskette. no tengo idea, y para colmo creo que no tengo los sources del kernel, osea dentro del /usr/src no tengo nada por lo que no puedo compilar los drivers que baje. Tienen que estar ahi o pueden estar en otro directorio?

supero una complicacion y aparece otra, asi debe ser como se aprende no?

saben que puede ser y que puedo hacer? gracias de nuevo y suerte amigos!

Nach0
SOLUCIÓN ACEPTADA
NachO, ¿te animás a comentar cómo lo solucionaste en el post anterior? Así le sirve a otro que venga con el mismo problema. Allí te ayudo sobre el tema del LiLO.

Siguiendo con el tema de los drivers. Sobre la falta del source del kernel. Para compilar el driver del módem lo único que necesitás son los headers del kernel. No conozco la convención de nombres en Slack pero sería un paquete kernel-development o algo así, y si necesitás compilar el kernel un paquete kernel sources. Buscalos en los CDs de slack que deben estar, sino siempre los podés bajar a parte. Ahora si solo compilás el driver del kernel vas a necesitar los headers del kernel que estás usando. Si vas a compilar kernel y driver podés hasta instalar otro kernel bajado de kernel.org. Tiene otras complicaciones, pero por ejemplo, si quisieras pasar a un kernel 2.6 que es una maza en autodetección de hardware es el camino a seguir.

Saludos.
bueno mauricio espero tu ayuda y la de los demas!
gracias por todo!
suerte
Nach0
bueno he resuelto el tema del modem (lo de kernel era que en el slack 9.0 que tenia faltaba la carpeta K, osea el kernel source, use el pgktool y lo instale desde un kernel de 2.4.22)
bueno ahora el tema del modem lo resolvi asi:
1- Baje el driver del siguiente link:
ftp://ftp.smlink.com/linux/unsupported/slmodem-2.9.4.tar.gz
2- Extraer y compilar:

tar -xvzf slmodem-2.9.4.tar.gz
cd slmodem*
./configure
make ; make install

3- Edita el sig. archivo:

/etc/rc.d/rc.local

y agrega las sigs. lineas

modprobe slamr
slmodemd &
ln -sf /dev/ttySL0 /dev/modem

4- Reinicia
P quizas tengan que editar el makefile por si no tienen el kernel en la ubiccion debida, en mi caso es en /usr/src/linux-2.4.22 <---- COSA QUE ANTES NO TENIA
bueno suerte y gracias por todo!
Nach0